$re = '~<table(.(?!</table>))*~m';
$str = 'Remove this tag: <img src="path/to/image">.
Also remove this tag: <img src="path/to/second/image">.
But don\'t touch this <img src="cid:1259asdhasi">.
<table>fgf</table>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;