import re
regex = re.compile(r"<table(.(?!</table>))*", flags=re.MULTILINE)
test_str = ("Remove this tag: <img src=\"path/to/image\">. \n"
"Also remove this tag: <img src=\"path/to/second/image\">. \n"
"But don't touch this <img src=\"cid:1259asdhasi\">.\n"
"<table>fgf</table>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)