#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)^(" & @CRLF & _
" (?![0.]+$)" & @CRLF & _
" (?:" & @CRLF & _
" " & @CRLF & _
" (?:^|\.)" & @CRLF & _
" (?:" & @CRLF & _
" \d|[1-9][0-9]|1\d{2}|2[-4]\d|25[0-5]" & @CRLF & _
" )" & @CRLF & _
" ){4}" & @CRLF & _
")$"
Local $sString = "0.0.0.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")