re = /^(
(?![0.]+$)
(?:
(?:^|\.)
(?:
\d|[1-9][0-9]|1\d{2}|2[-4]\d|25[0-5]
)
){4}
)$/x
str = '0.0.0.0'
# Print the match result
str.match(re) do |match|
puts match.to_s
end