import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\n"
+ " (?![0.]+$)\n"
+ " (?:\n"
+ " \n"
+ " (?:^|\\.)\n"
+ " (?:\n"
+ " \\d|[1-9][0-9]|1\\d{2}|2[-4]\\d|25[0-5]\n"
+ " )\n"
+ " ){4}\n"
+ ")$";
final String string = "0.0.0.0";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}