import re
regex = re.compile(r"""
^(
(?![0.]+$)
(?:
(?:^|\.)
(?:
\d|[1-9][0-9]|1\d{2}|2[-4]\d|25[0-5]
)
){4}
)$
""", flags=re.VERBOSE)
test_str = "0.0.0.0"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")