package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(
(?![0.]+$)
(?:
(?:^|\.)
(?:
\d|[1-9][0-9]|1\d{2}|2[-4]\d|25[0-5]
)
){4}
)$`)
var str = `0.0.0.0`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}