using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(
(?![0.]+$)
(?:
(?:^|\.)
(?:
\d|[1-9][0-9]|1\d{2}|2[-4]\d|25[0-5]
)
){4}
)$";
string input = @"0.0.0.0";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}