import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2}.\\d{2}.\\d{2}).+(\\w{3}).+\\w{3}.+(\\w{2}\\s\\d{4}).+(\\d{2}:\\d{2}\\n).+(\\d{2}.\\d{2}.\\d{2}).+(\\w{2}\\s\\d{4}).+(\\d{2}:\\d{2}\\n).+((FNC|PXO)\\d{3})";
final String string = "***NEUBUCHUNG ***\n"
+ " 24.01.15 TXL FNC AB 2306 11:40 15:20\n"
+ " 31.01.15 FNC TXL AB 2307 16:05\n"
+ " FNC044 RESIDENCIAL VILA LUSITANI 9000-120 FUNCHAL\n"
+ " 1 DOPPELZIMMER FRUEHSTUECK\n"
+ " SPO1101\n"
+ " INKL. REISELEITUNG UND TRANSFER AB/BIS\n"
+ " FLUGHAFEN\n"
+ " F368966 HERR EIDAM, KLAUS 54\n"
+ " F368966 FRAU EIDAM, SONJA 54";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}