import Foundation
let pattern = #"(\d{2}.\d{2}.\d{2}).+(\w{3}).+\w{3}.+(\w{2}\s\d{4}).+(\d{2}:\d{2}\n).+(\d{2}.\d{2}.\d{2}).+(\w{2}\s\d{4}).+(\d{2}:\d{2}\n).+((FNC|PXO)\d{3})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
***NEUBUCHUNG ***
24.01.15 TXL FNC AB 2306 11:40 15:20
31.01.15 FNC TXL AB 2307 16:05
FNC044 RESIDENCIAL VILA LUSITANI 9000-120 FUNCHAL
1 DOPPELZIMMER FRUEHSTUECK
SPO1101
INKL. REISELEITUNG UND TRANSFER AB/BIS
FLUGHAFEN
F368966 HERR EIDAM, KLAUS 54
F368966 FRAU EIDAM, SONJA 54
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)