const regex = /(\d{2}.\d{2}.\d{2}).+(\w{3}).+\w{3}.+(\w{2}\s\d{4}).+(\d{2}:\d{2}\n).+(\d{2}.\d{2}.\d{2}).+(\w{2}\s\d{4}).+(\d{2}:\d{2}\n).+((FNC|PXO)\d{3})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2}.\\d{2}.\\d{2}).+(\\w{3}).+\\w{3}.+(\\w{2}\\s\\d{4}).+(\\d{2}:\\d{2}\\n).+(\\d{2}.\\d{2}.\\d{2}).+(\\w{2}\\s\\d{4}).+(\\d{2}:\\d{2}\\n).+((FNC|PXO)\\d{3})', 'g')
const str = `***NEUBUCHUNG ***
24.01.15 TXL FNC AB 2306 11:40 15:20
31.01.15 FNC TXL AB 2307 16:05
FNC044 RESIDENCIAL VILA LUSITANI 9000-120 FUNCHAL
1 DOPPELZIMMER FRUEHSTUECK
SPO1101
INKL. REISELEITUNG UND TRANSFER AB/BIS
FLUGHAFEN
F368966 HERR EIDAM, KLAUS 54
F368966 FRAU EIDAM, SONJA 54`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}