# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{2}.\d{2}.\d{2}).+(\w{3}).+\w{3}.+(\w{2}\s\d{4}).+(\d{2}:\d{2}\n).+(\d{2}.\d{2}.\d{2}).+(\w{2}\s\d{4}).+(\d{2}:\d{2}\n).+((FNC|PXO)\d{3})"
test_str = ("***NEUBUCHUNG ***\n"
" 24.01.15 TXL FNC AB 2306 11:40 15:20\n"
" 31.01.15 FNC TXL AB 2307 16:05\n"
" FNC044 RESIDENCIAL VILA LUSITANI 9000-120 FUNCHAL\n"
" 1 DOPPELZIMMER FRUEHSTUECK\n"
" SPO1101\n"
" INKL. REISELEITUNG UND TRANSFER AB/BIS\n"
" FLUGHAFEN\n"
" F368966 HERR EIDAM, KLAUS 54\n"
" F368966 FRAU EIDAM, SONJA 54")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.