use strict;
my $str = '***NEUBUCHUNG ***
24.01.15 TXL FNC AB 2306 11:40 15:20
31.01.15 FNC TXL AB 2307 16:05
FNC044 RESIDENCIAL VILA LUSITANI 9000-120 FUNCHAL
1 DOPPELZIMMER FRUEHSTUECK
SPO1101
INKL. REISELEITUNG UND TRANSFER AB/BIS
FLUGHAFEN
F368966 HERR EIDAM, KLAUS 54
F368966 FRAU EIDAM, SONJA 54';
my $regex = qr/(\d{2}.\d{2}.\d{2}).+(\w{3}).+\w{3}.+(\w{2}\s\d{4}).+(\d{2}:\d{2}\n).+(\d{2}.\d{2}.\d{2}).+(\w{2}\s\d{4}).+(\d{2}:\d{2}\n).+((FNC|PXO)\d{3})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}