$re = '/(\d{2}.\d{2}.\d{2}).+(\w{3}).+\w{3}.+(\w{2}\s\d{4}).+(\d{2}:\d{2}\n).+(\d{2}.\d{2}.\d{2}).+(\w{2}\s\d{4}).+(\d{2}:\d{2}\n).+((FNC|PXO)\d{3})/';
$str = '***NEUBUCHUNG ***
24.01.15 TXL FNC AB 2306 11:40 15:20
31.01.15 FNC TXL AB 2307 16:05
FNC044 RESIDENCIAL VILA LUSITANI 9000-120 FUNCHAL
1 DOPPELZIMMER FRUEHSTUECK
SPO1101
INKL. REISELEITUNG UND TRANSFER AB/BIS
FLUGHAFEN
F368966 HERR EIDAM, KLAUS 54
F368966 FRAU EIDAM, SONJA 54';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);