#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:10|[0-9](?:\.(?:[27]?5)?0*)?)$"
Local $sString = "0" & @CRLF & _
"11" & @CRLF & _
"10.5" & @CRLF & _
"9.5" & @CRLF & _
"9.50" & @CRLF & _
"9.2" & @CRLF & _
"9.25" & @CRLF & _
"9.5000000" & @CRLF & _
"9.0" & @CRLF & _
"9" & @CRLF & _
"0.0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")