$re = '/^(?:10|[0-9](?:\.(?:[27]?5)?0*)?)$/m';
$str = '0
11
10.5
9.5
9.50
9.2
9.25
9.5000000
9.0
9
0.0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);