package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:10|[0-9](?:\.(?:[27]?5)?0*)?)$`)
var str = `0
11
10.5
9.5
9.50
9.2
9.25
9.5000000
9.0
9
0.0
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}