using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:10|[0-9](?:\.(?:[27]?5)?0*)?)$";
string input = @"0
11
10.5
9.5
9.50
9.2
9.25
9.5000000
9.0
9
0.0
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}