// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:10|[0-9](?:\.(?:[27]?5)?0*)?)$").unwrap();
let string = "0
11
10.5
9.5
9.50
9.2
9.25
9.5000000
9.0
9
0.0
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}