import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:10|[0-9](?:\\.(?:[27]?5)?0*)?)$";
final String string = "0\n"
+ "11\n"
+ "10.5\n"
+ "9.5\n"
+ "9.50\n"
+ "9.2\n"
+ "9.25\n"
+ "9.5000000\n"
+ "9.0\n"
+ "9\n"
+ "0.0\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}