import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\.(_)?[a-z]+-[a-z0-9-]+((_{2}|-{2})?[a-z0-9-]+)?(-{2}[a-z0-9-]+)?[a-z0-9]$";
final String string = ".o-layout\n\n"
+ ".c-btn--\n\n"
+ ".o-layout__item\n\n"
+ ".has-dropDown\n\n"
+ ".o-layout--fixed\n\n"
+ ".u-color-primary\n\n"
+ ".foo_bar\n\n"
+ ".s-cms-content\n\n"
+ ".title__sub\n\n"
+ ".t-light\n\n"
+ ".c-date-picker__calendar\n\n"
+ ".heading\n\n"
+ ".o-matrix__item--full\n\n"
+ "._c-footer__copyright";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}