// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\.(_)?[a-z]+-[a-z0-9-]+((_{2}|-{2})?[a-z0-9-]+)?(-{2}[a-z0-9-]+)?[a-z0-9]$").unwrap();
let string = ".o-layout
.c-btn--
.o-layout__item
.has-dropDown
.o-layout--fixed
.u-color-primary
.foo_bar
.s-cms-content
.title__sub
.t-light
.c-date-picker__calendar
.heading
.o-matrix__item--full
._c-footer__copyright";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}