use strict;
my $str = '.o-layout
.c-btn--
.o-layout__item
.has-dropDown
.o-layout--fixed
.u-color-primary
.foo_bar
.s-cms-content
.title__sub
.t-light
.c-date-picker__calendar
.heading
.o-matrix__item--full
._c-footer__copyright';
my $regex = qr/^\.(_)?[a-z]+-[a-z0-9-]+((_{2}|-{2})?[a-z0-9-]+)?(-{2}[a-z0-9-]+)?[a-z0-9]$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}