# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\.(_)?[a-z]+-[a-z0-9-]+((_{2}|-{2})?[a-z0-9-]+)?(-{2}[a-z0-9-]+)?[a-z0-9]$"
test_str = (".o-layout\n\n"
".c-btn--\n\n"
".o-layout__item\n\n"
".has-dropDown\n\n"
".o-layout--fixed\n\n"
".u-color-primary\n\n"
".foo_bar\n\n"
".s-cms-content\n\n"
".title__sub\n\n"
".t-light\n\n"
".c-date-picker__calendar\n\n"
".heading\n\n"
".o-matrix__item--full\n\n"
"._c-footer__copyright")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.