re = /^\.(_)?[a-z]+-[a-z0-9-]+((_{2}|-{2})?[a-z0-9-]+)?(-{2}[a-z0-9-]+)?[a-z0-9]$/m
str = '.o-layout
.c-btn--
.o-layout__item
.has-dropDown
.o-layout--fixed
.u-color-primary
.foo_bar
.s-cms-content
.title__sub
.t-light
.c-date-picker__calendar
.heading
.o-matrix__item--full
._c-footer__copyright'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end