const regex = /^\.(_)?[a-z]+-[a-z0-9-]+((_{2}|-{2})?[a-z0-9-]+)?(-{2}[a-z0-9-]+)?[a-z0-9]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\.(_)?[a-z]+-[a-z0-9-]+((_{2}|-{2})?[a-z0-9-]+)?(-{2}[a-z0-9-]+)?[a-z0-9]$', 'gm')
const str = `.o-layout
.c-btn--
.o-layout__item
.has-dropDown
.o-layout--fixed
.u-color-primary
.foo_bar
.s-cms-content
.title__sub
.t-light
.c-date-picker__calendar
.heading
.o-matrix__item--full
._c-footer__copyright`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}