#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?<=\D)[+-]\d+)|\d+"
Local $sString = "a := -1" & @CRLF & _
"y := +2" & @CRLF & _
"b := 2-2" & @CRLF & _
"c := 3+4" & @CRLF & _
"z := 20 + 42" & @CRLF & _
"funcao(-1)" & @CRLF & _
"funcao( -1)" & @CRLF & _
"funcao(a, -1)" & @CRLF & _
"-1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")