re = /((?<=\D)[+-]\d+)|\d+/
str = 'a := -1
y := +2
b := 2-2
c := 3+4
z := 20 + 42
funcao(-1)
funcao( -1)
funcao(a, -1)
-1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end