import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=\\D)[+-]\\d+)|\\d+";
final String string = "a := -1\n"
+ "y := +2\n"
+ "b := 2-2\n"
+ "c := 3+4\n"
+ "z := 20 + 42\n"
+ "funcao(-1)\n"
+ "funcao( -1)\n"
+ "funcao(a, -1)\n"
+ "-1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}