import re
regex = re.compile(r"((?<=\D)[+-]\d+)|\d+")
test_str = ("a := -1\n"
"y := +2\n"
"b := 2-2\n"
"c := 3+4\n"
"z := 20 + 42\n"
"funcao(-1)\n"
"funcao( -1)\n"
"funcao(a, -1)\n"
"-1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")