using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(className=""[^""]+)([A-Z])([^""]+)([A-Z])([^""]+"")";
string substitution = @"$1-\L$2$3-\L$4$5";
string input = @"<div className=""myFavoriteClass""><span className=""myFavoriteClass"" ><span className=""myFavorite"" ><span className=""myFavoriteClassName"" >";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}