import re
regex = re.compile(r"(className=\"[^\"]+)([A-Z])([^\"]+)([A-Z])([^\"]+\")", flags=re.MULTILINE)
test_str = "<div className=\"myFavoriteClass\"><span className=\"myFavoriteClass\" ><span className=\"myFavorite\" ><span className=\"myFavoriteClassName\" >"
subst = "$1-\\L$2$3-\\L$4$5"
result = regex.sub(subst, test_str)
if result:
print(result)