// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(className="[^"]+)([A-Z])([^"]+)([A-Z])([^"]+")"#).unwrap();
let string = "<div className=\"myFavoriteClass\"><span className=\"myFavoriteClass\" ><span className=\"myFavorite\" ><span className=\"myFavoriteClassName\" >";
let substitution = "$1-\\L$2$3-\\L$4$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}