re = /(className="[^"]+)([A-Z])([^"]+)([A-Z])([^"]+")/m
str = '<div className="myFavoriteClass"><span className="myFavoriteClass" ><span className="myFavorite" ><span className="myFavoriteClassName" >'
subst = '$1-\\L$2$3-\\L$4$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result