const regex = /(className="[^"]+)([A-Z])([^"]+)([A-Z])([^"]+")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(className="[^"]+)([A-Z])([^"]+)([A-Z])([^"]+")', 'gm')
const str = `<div className="myFavoriteClass"><span className="myFavoriteClass" ><span className="myFavorite" ><span className="myFavoriteClassName" >`;
const subst = `$1-\L$2$3-\L$4$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);