$re = '/(className="[^"]+)([A-Z])([^"]+)([A-Z])([^"]+")/m';
$str = '<div className="myFavoriteClass"><span className="myFavoriteClass" ><span className="myFavorite" ><span className="myFavoriteClassName" >';
$subst = "$1-\L$2$3-\L$4$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;