import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{2}-?\\d{6}-?\\d{6}-?(?:\\d{1,2})?\\b";
final String string = "22-412314-441123-1\n\n"
+ "22-412314-441123-12\n\n"
+ "2a-412314-441123-12\n\n\n"
+ "22412314-441123-1\n\n"
+ "2241231444112312\n\n"
+ "22412314441123123\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}