use strict;
my $str = '22-412314-441123-1
22-412314-441123-12
2a-412314-441123-12
22412314-441123-1
2241231444112312
22412314441123123
';
my $regex = qr/\b\d{2}-?\d{6}-?\d{6}-?(?:\d{1,2})?\b/isp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}