// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)\b\d{2}-?\d{6}-?\d{6}-?(?:\d{1,2})?\b").unwrap();
let string = "22-412314-441123-1
22-412314-441123-12
2a-412314-441123-12
22412314-441123-1
2241231444112312
22412314441123123
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}