const regex = /\b\d{2}-?\d{6}-?\d{6}-?(?:\d{1,2})?\b/isg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{2}-?\\d{6}-?\\d{6}-?(?:\\d{1,2})?\\b', 'isg')
const str = `22-412314-441123-1
22-412314-441123-12
2a-412314-441123-12
22412314-441123-1
2241231444112312
22412314441123123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}