$re = '/\b\d{2}-?\d{6}-?\d{6}-?(?:\d{1,2})?\b/is';
$str = '22-412314-441123-1
22-412314-441123-12
2a-412314-441123-12
22412314-441123-1
2241231444112312
22412314441123123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);