const regex = /^(\w+)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+)(.*)', 'gm')
const str = `jon52_rs - £5
caneflagi - £5
Tehhguam - £5
Clapu - £5-05`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);