import re
regex = re.compile(r"^(\w+)(.*)", flags=re.MULTILINE)
test_str = ("jon52_rs - £5 \n"
"caneflagi - £5 \n"
"Tehhguam - £5 \n"
"Clapu - £5-05")
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)