$re = '/^(\w+)(.*)/m';
$str = 'jon52_rs - £5
caneflagi - £5
Tehhguam - £5
Clapu - £5-05';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;