re = /^(\w+)(.*)/m
str = 'jon52_rs - £5
caneflagi - £5
Tehhguam - £5
Clapu - £5-05'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result