#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!00)[0-5]\d\.[05]|60\.0|99\.9$"
Local $sString = "01.0" & @CRLF & _
"02.0" & @CRLF & _
"02.5" & @CRLF & _
"50.0" & @CRLF & _
"10.0" & @CRLF & _
"20.0" & @CRLF & _
"30.5" & @CRLF & _
"40.5" & @CRLF & _
"50.5" & @CRLF & _
"59.0" & @CRLF & _
"59.5" & @CRLF & _
"60.0" & @CRLF & _
"99.9" & @CRLF & _
"" & @CRLF & _
"59.1" & @CRLF & _
"34.9" & @CRLF & _
"60.5" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")