import re
regex = re.compile(r"^(?!00)[0-5]\d\.[05]|60\.0|99\.9$", flags=re.MULTILINE)
test_str = ("01.0\n"
"02.0\n"
"02.5\n"
"50.0\n"
"10.0\n"
"20.0\n"
"30.5\n"
"40.5\n"
"50.5\n"
"59.0\n"
"59.5\n"
"60.0\n"
"99.9\n\n"
"59.1\n"
"34.9\n"
"60.5\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")