$re = '/^(?!00)[0-5]\d\.[05]|60\.0|99\.9$/m';
$str = '01.0
02.0
02.5
50.0
10.0
20.0
30.5
40.5
50.5
59.0
59.5
60.0
99.9
59.1
34.9
60.5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);