import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!00)[0-5]\\d\\.[05]|60\\.0|99\\.9$";
final String string = "01.0\n"
+ "02.0\n"
+ "02.5\n"
+ "50.0\n"
+ "10.0\n"
+ "20.0\n"
+ "30.5\n"
+ "40.5\n"
+ "50.5\n"
+ "59.0\n"
+ "59.5\n"
+ "60.0\n"
+ "99.9\n\n"
+ "59.1\n"
+ "34.9\n"
+ "60.5\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}