using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!00)[0-5]\d\.[05]|60\.0|99\.9$";
string input = @"01.0
02.0
02.5
50.0
10.0
20.0
30.5
40.5
50.5
59.0
59.5
60.0
99.9
59.1
34.9
60.5
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}